use strict;
my $str = '000450';
my $regex = qr/\G0/p;
my $subst = 'x';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";