#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{6}(?:\d{2}\d{2})?[CD][A-Z]?[0-9,]{1,15}[A-Z]{1,4}[A-Za-z0-9]{1,16}(?:\/\/[0-9A-Z]{1,16})?\s*\n[0-9]{1,3}\?[0-9]{0,6}"
Local $sString = "1812121212DD2220,31NTRFNONREF" & @CRLF & _
"502?102330" & @CRLF & _
"" & @CRLF & _
"Line 2" & @CRLF & _
"" & @CRLF & _
"1811091109CD20693,12NTRFRMSOIC110871941//0016RFXXXXXXX" & @CRLF & _
"206?000801"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")