# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{6}(?:\d{2}\d{2})?[CD][A-Z]?[0-9,]{1,15}[A-Z]{1,4}[A-Za-z0-9]{1,16}(?:\/\/[0-9A-Z]{1,16})?\s*\n[0-9]{1,3}\?[0-9]{0,6}"
test_str = ("1812121212DD2220,31NTRFNONREF\n"
"502?102330\n\n"
"Line 2\n\n"
"1811091109CD20693,12NTRFRMSOIC110871941//0016RFXXXXXXX\n"
"206?000801")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.