const regex = /\d{6}(?:\d{2}\d{2})?[CD][A-Z]?[0-9,]{1,15}[A-Z]{1,4}[A-Za-z0-9]{1,16}(?:\/\/[0-9A-Z]{1,16})?\s*\n[0-9]{1,3}\?[0-9]{0,6}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{6}(?:\\d{2}\\d{2})?[CD][A-Z]?[0-9,]{1,15}[A-Z]{1,4}[A-Za-z0-9]{1,16}(?:\\\/\\\/[0-9A-Z]{1,16})?\\s*\\n[0-9]{1,3}\\?[0-9]{0,6}', 'gm')
const str = `1812121212DD2220,31NTRFNONREF
502?102330
Line 2
1811091109CD20693,12NTRFRMSOIC110871941//0016RFXXXXXXX
206?000801`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}