$re = '/\d{6}(?:\d{2}\d{2})?[CD][A-Z]?[0-9,]{1,15}[A-Z]{1,4}[A-Za-z0-9]{1,16}(?:\/\/[0-9A-Z]{1,16})?\s*\n[0-9]{1,3}\?[0-9]{0,6}/m';
$str = '1812121212DD2220,31NTRFNONREF
502?102330
Line 2
1811091109CD20693,12NTRFRMSOIC110871941//0016RFXXXXXXX
206?000801';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);