import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{6}(?:\\d{2}\\d{2})?[CD][A-Z]?[0-9,]{1,15}[A-Z]{1,4}[A-Za-z0-9]{1,16}(?:\\/\\/[0-9A-Z]{1,16})?\\s*\\n[0-9]{1,3}\\?[0-9]{0,6}";
final String string = "1812121212DD2220,31NTRFNONREF\n"
+ "502?102330\n\n"
+ "Line 2\n\n"
+ "1811091109CD20693,12NTRFRMSOIC110871941//0016RFXXXXXXX\n"
+ "206?000801";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}