using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\""access_token\"":\s\"")[^\""]*";
string input = @"{""access_token"": ""D2L6O3vxWHlJasdlhsdflhvjODaBLD5HiJKd0y33Nt7LcVtp4S5phZ1-HvqHwn8qIB3TflApEluTvG09rO3M="", ""scopes"": ""repository"", ""expires_in"": 3600, ""refresh_token"": ""ZfXk7JsdgESBZMuMHE"", ""token_type"": ""bearer""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}