const regex = /(?<=\"access_token\":\s\")[^\"]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\"access_token\\":\\s\\")[^\\"]*', 'g')
const str = `{"access_token": "D2L6O3vxWHlJasdlhsdflhvjODaBLD5HiJKd0y33Nt7LcVtp4S5phZ1-HvqHwn8qIB3TflApEluTvG09rO3M=", "scopes": "repository", "expires_in": 3600, "refresh_token": "ZfXk7JsdgESBZMuMHE", "token_type": "bearer"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}