re = /(?<=\"access_token\":\s\")[^\"]*/
str = '{"access_token": "D2L6O3vxWHlJasdlhsdflhvjODaBLD5HiJKd0y33Nt7LcVtp4S5phZ1-HvqHwn8qIB3TflApEluTvG09rO3M=", "scopes": "repository", "expires_in": 3600, "refresh_token": "ZfXk7JsdgESBZMuMHE", "token_type": "bearer"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end