use strict;
my $str = '{"access_token": "D2L6O3vxWHlJasdlhsdflhvjODaBLD5HiJKd0y33Nt7LcVtp4S5phZ1-HvqHwn8qIB3TflApEluTvG09rO3M=", "scopes": "repository", "expires_in": 3600, "refresh_token": "ZfXk7JsdgESBZMuMHE", "token_type": "bearer"}';
my $regex = qr/(?<=\"access_token\":\s\")[^\"]*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}