using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[Dd][- ]?)?\d{5}$";
string input = @"12345
D12345
D-12345
D 12345
d12345
d-12345
d 12345
asdf
1234
d1234
p12345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}