import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[Dd][- ]?)?\\d{5}$";
final String string = "12345\n"
+ "D12345\n"
+ "D-12345\n"
+ "D 12345\n"
+ "d12345\n"
+ "d-12345\n"
+ "d 12345\n"
+ "asdf\n"
+ "1234\n"
+ "d1234\n"
+ "p12345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}