const regex = /^(?:[Dd][- ]?)?\d{5}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[Dd][- ]?)?\\d{5}$', 'gm')
const str = `12345
D12345
D-12345
D 12345
d12345
d-12345
d 12345
asdf
1234
d1234
p12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}