// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[Dd][- ]?)?\d{5}$").unwrap();
let string = "12345
D12345
D-12345
D 12345
d12345
d-12345
d 12345
asdf
1234
d1234
p12345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}