$re = '/^(?:[Dd][- ]?)?\d{5}$/m';
$str = '12345
D12345
D-12345
D 12345
d12345
d-12345
d 12345
asdf
1234
d1234
p12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);