# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:Y=\d","|\G)[^,"]*\K,//gm;t' <<< "Y=6\",\"~2807-1 Q12m. Plate(s), screw(s), rod(s) or pin(s) in any bone - NO\""