re = /(?:Y=\d","|\G)[^,"]*\K,/m
str = 'Y=6","~2807-1 Q12m. Plate(s), screw(s), rod(s) or pin(s) in any bone - NO"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result