$re = '/(?:Y=\d","|\G)[^,"]*\K,/m';
$str = 'Y=6","~2807-1 Q12m. Plate(s), screw(s), rod(s) or pin(s) in any bone - NO"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;