const regex = /(?:Y=\d","|\G)[^,"]*\K,/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:Y=\\d","|\\G)[^,"]*\\K,', 'gm')
const str = `Y=6","~2807-1 Q12m. Plate(s), screw(s), rod(s) or pin(s) in any bone - NO"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);