use strict;
my $str = 'Y=6","~2807-1 Q12m. Plate(s), screw(s), rod(s) or pin(s) in any bone - NO"';
my $regex = qr/(?:Y=\d","|\G)[^,"]*\K,/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";