#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}(,\d{2})*$"
Local $sString = "" & @CRLF & _
"80,01,00" & @CRLF & _
"80,00" & @CRLF & _
"01" & @CRLF & _
"00,80,01,02" & @CRLF & _
"The not allowed values are as below:" & @CRLF & _
"" & @CRLF & _
"80," & @CRLF & _
",01," & @CRLF & _
",00" & @CRLF & _
"8" & @CRLF & _
"800" & @CRLF & _
"" & @CRLF & _
" 80, --> with comma in the end." & @CRLF & _
",01, --> comma at the start and end." & @CRLF & _
",00 --> comma at the start." & @CRLF & _
" 8 --> with only one digit" & @CRLF & _
"800 --> with three digits " & @CRLF & _
"I have tried the below regex pattern:" & @CRLF & _
"" & @CRLF & _
"^(*([0-9][0-9][,])+([0-9][0-9])*([,][0-9][0-9]))$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")