use strict;
my $str = '
80,01,00
80,00
01
00,80,01,02
The not allowed values are as below:
80,
,01,
,00
8
800
80, --> with comma in the end.
,01, --> comma at the start and end.
,00 --> comma at the start.
8 --> with only one digit
800 --> with three digits
I have tried the below regex pattern:
^(*([0-9][0-9][,])+([0-9][0-9])*([,][0-9][0-9]))$';
my $regex = qr/^\d{2}(,\d{2})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}