import Foundation
let pattern = #"^\d{2}(,\d{2})*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
80,01,00
80,00
01
00,80,01,02
The not allowed values are as below:
80,
,01,
,00
8
800
80, --> with comma in the end.
,01, --> comma at the start and end.
,00 --> comma at the start.
8 --> with only one digit
800 --> with three digits
I have tried the below regex pattern:
^(*([0-9][0-9][,])+([0-9][0-9])*([,][0-9][0-9]))$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)