using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{2}(,\d{2})*$";
string input = @"
80,01,00
80,00
01
00,80,01,02
The not allowed values are as below:
80,
,01,
,00
8
800
80, --> with comma in the end.
,01, --> comma at the start and end.
,00 --> comma at the start.
8 --> with only one digit
800 --> with three digits
I have tried the below regex pattern:
^(*([0-9][0-9][,])+([0-9][0-9])*([,][0-9][0-9]))$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}