$re = '/^\d{2}(,\d{2})*$/m';
$str = '
80,01,00
80,00
01
00,80,01,02
The not allowed values are as below:
80,
,01,
,00
8
800
80, --> with comma in the end.
,01, --> comma at the start and end.
,00 --> comma at the start.
8 --> with only one digit
800 --> with three digits
I have tried the below regex pattern:
^(*([0-9][0-9][,])+([0-9][0-9])*([,][0-9][0-9]))$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);