#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "--|<\w[^>]+(*SKIP)(*F)"
Local $sString = "" & @CRLF & _
" -- <div data-url=" -- "> -- </div>" & @CRLF & _
" -- <div data-url=" -- "> -- </div>" & @CRLF & _
""
Local $sSubst = "–"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)