$re = '~--|<\w[^>]+(*SKIP)(*F)~';
$str = '
-- <div data-url=" -- "> -- </div>
-- <div data-url=" -- "> -- </div>
';
$subst = "–";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;