const regex = new RegExp('--|<\\w[^>]+(*SKIP)(*F)', 'g')
const str = `
-- <div data-url=" -- "> -- </div>
-- <div data-url=" -- "> -- </div>
`;
const subst = `–`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);