import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "--|<\\w[^>]+(*SKIP)(*F)";
final String string = "\n"
+ " -- <div data-url=\" -- \"> -- </div>\n"
+ " -- <div data-url=\" -- \"> -- </div>\n";
final String subst = "–";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}