// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"--|<\w[^>]+(*SKIP)(*F)").unwrap();
let string = "
-- <div data-url=\" -- \"> -- </div>
-- <div data-url=\" -- \"> -- </div>
";
let substitution = "–";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}