# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9]+(\.[0-9]{2})?)\|((?:[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,?)(?:[A-Z]{2}[+*]?([0-9]+)?[*+]?([0-9]+)?,?[A-Z]{2}?[*+]?([0-9]+)?[+*]?([0-9]+)?)?)(\s+"(.+?)")?/(\1) (\3) (\11)/gm;t' <<< "62.00|LQ+2*2,FP,MD*3
30|LQ \"Burgers\"
35.15|LQ*2,FP+2*4,MD*3+4 \"Potatoes\"
35.15|LQ,FP,MD"