# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]+(\.[0-9]{2})?)\|((?:[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,?)(?:[A-Z]{2}[+*]?([0-9]+)?[*+]?([0-9]+)?,?[A-Z]{2}?[*+]?([0-9]+)?[+*]?([0-9]+)?)?)(\s+\"(.+?)\")?"
test_str = ("62.00|LQ+2*2,FP,MD*3\n"
"30|LQ \"Burgers\"\n"
"35.15|LQ*2,FP+2*4,MD*3+4 \"Potatoes\"\n"
"35.15|LQ,FP,MD")
subst = "(\\1) (\\3) (\\11)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.