#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([0-9]+(\.[0-9]{2})?)\|((?:[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,?)(?:[A-Z]{2}[+*]?([0-9]+)?[*+]?([0-9]+)?,?[A-Z]{2}?[*+]?([0-9]+)?[+*]?([0-9]+)?)?)(\s+"(.+?)")?"
Local $sString = "62.00|LQ+2*2,FP,MD*3" & @CRLF & _
"30|LQ "Burgers"" & @CRLF & _
"35.15|LQ*2,FP+2*4,MD*3+4 "Potatoes"" & @CRLF & _
"35.15|LQ,FP,MD"
Local $sSubst = "(\1) (\3) (\11)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)