using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]+(\.[0-9]{2})?)\|((?:[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,?)(?:[A-Z]{2}[+*]?([0-9]+)?[*+]?([0-9]+)?,?[A-Z]{2}?[*+]?([0-9]+)?[+*]?([0-9]+)?)?)(\s+""(.+?)"")?";
string substitution = @"(\1) (\3) (\11)";
string input = @"62.00|LQ+2*2,FP,MD*3
30|LQ ""Burgers""
35.15|LQ*2,FP+2*4,MD*3+4 ""Potatoes""
35.15|LQ,FP,MD";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}