// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([0-9]+(\.[0-9]{2})?)\|((?:[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,?)(?:[A-Z]{2}[+*]?([0-9]+)?[*+]?([0-9]+)?,?[A-Z]{2}?[*+]?([0-9]+)?[+*]?([0-9]+)?)?)(\s+"(.+?)")?"#).unwrap();
let string = "62.00|LQ+2*2,FP,MD*3
30|LQ \"Burgers\"
35.15|LQ*2,FP+2*4,MD*3+4 \"Potatoes\"
35.15|LQ,FP,MD";
let substitution = "(\\1) (\\3) (\\11)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}