#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[ATTACH(?: \w+="\w+(?:\.\w+)*")*]"
Local $sString = "[ATTACH]" & @CRLF & _
"" & @CRLF & _
"[ATTACH type="full"]" & @CRLF & _
"" & @CRLF & _
"[ATTACH type="full" alt="3vmw5j.jpg"]" & @CRLF & _
"" & @CRLF & _
"[ATTACH alt="3vmw5j.jpg" type="full"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")