re = /\[ATTACH(?: \w+="\w+(?:\.\w+)*")*]/m
str = '[ATTACH]
[ATTACH type="full"]
[ATTACH type="full" alt="3vmw5j.jpg"]
[ATTACH alt="3vmw5j.jpg" type="full"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end