using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[ATTACH(?: \w+=""\w+(?:\.\w+)*"")*]";
string input = @"[ATTACH]
[ATTACH type=""full""]
[ATTACH type=""full"" alt=""3vmw5j.jpg""]
[ATTACH alt=""3vmw5j.jpg"" type=""full""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}