import re
regex = re.compile(r"\[ATTACH(?: \w+=\"\w+(?:\.\w+)*\")*]", flags=re.MULTILINE)
test_str = ("[ATTACH]\n\n"
"[ATTACH type=\"full\"]\n\n"
"[ATTACH type=\"full\" alt=\"3vmw5j.jpg\"]\n\n"
"[ATTACH alt=\"3vmw5j.jpg\" type=\"full\"]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")