import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[ATTACH(?: \\w+=\"\\w+(?:\\.\\w+)*\")*]";
final String string = "[ATTACH]\n\n"
+ "[ATTACH type=\"full\"]\n\n"
+ "[ATTACH type=\"full\" alt=\"3vmw5j.jpg\"]\n\n"
+ "[ATTACH alt=\"3vmw5j.jpg\" type=\"full\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}