package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(-?\d+\.?\d*E?\-?\d*)$`)
var str = `1.34E-200
12
1E100
123.45
Hello world
-12.45E-12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}