import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-?\\d+\\.?\\d*E?\\-?\\d*)$";
final String string = "1.34E-200\n"
+ "12\n"
+ "1E100\n"
+ "123.45\n"
+ "Hello world\n"
+ "-12.45E-12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}