// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(-?\d+\.?\d*E?\-?\d*)$").unwrap();
let string = "1.34E-200
12
1E100
123.45
Hello world
-12.45E-12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}