using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d]*?)([dD][\d]*)(([\+\-\*])[\d]*|([\+\-\*])\(([a-zA-Z]*)\))?";
string input = @"1D10*10
D10+20
D10+D10
D10+(Strength)
D10+20+1*2+(Strength)+D10";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}