$re = '/([\d]*?)([dD][\d]*)(([\+\-\*])[\d]*|([\+\-\*])\(([a-zA-Z]*)\))?/mi';
$str = '1D10*10
D10+20
D10+D10
D10+(Strength)
D10+20+1*2+(Strength)+D10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);