import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\d]*?)([dD][\\d]*)(([\\+\\-\\*])[\\d]*|([\\+\\-\\*])\\(([a-zA-Z]*)\\))?";
final String string = "1D10*10\n"
+ "D10+20\n"
+ "D10+D10\n"
+ "D10+(Strength)\n"
+ "D10+20+1*2+(Strength)+D10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}