re = /([\d]*?)([dD][\d]*)(([\+\-\*])[\d]*|([\+\-\*])\(([a-zA-Z]*)\))?/mi
str = '1D10*10
D10+20
D10+D10
D10+(Strength)
D10+20+1*2+(Strength)+D10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end