using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+([chds]).+\1.+\1.+\1.+\1";
string input = @"10hJh7hAh2h
10cJcQcKcAc
10cJcQcKhAh // No Match
2d3d4d5d6d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}