$re = '/.+([chds]).+\1.+\1.+\1.+\1/m';
$str = '10hJh7hAh2h
10cJcQcKcAc
10cJcQcKhAh // No Match
2d3d4d5d6d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);