const regex = /.+([chds]).+\1.+\1.+\1.+\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+([chds]).+\\1.+\\1.+\\1.+\\1', 'gm')
const str = `10hJh7hAh2h
10cJcQcKcAc
10cJcQcKhAh // No Match
2d3d4d5d6d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}